All features are restored in the Signal Platform after the AWS outage has been resolved. Thank you for your patience and understanding.
Posted Oct 20, 2025 - 23:01 EDT
Update
We have brought the Signal Platform back online, but certain features, like Signal Wealth, may not be available until the AWS outage has fully recovered. We appreciate your patience and understanding.
Posted Oct 20, 2025 - 17:47 EDT
Update
As AWS is still working through their outage, we're noticing issues logging in to the Signal Platform. We're working on bringing access back up. We appreciate your patience and understanding as our team works towards a resolution.
Posted Oct 20, 2025 - 16:16 EDT
Identified
The ongoing Amazon Web Services (AWS) outage is impacting functionality across the Signal Platform including but not limited to carrier updates, policy/account data, and trading turnaround times. We appreciate your patience and understanding as our team works towards a resolution.
Posted Oct 20, 2025 - 14:10 EDT
This incident affected: Advisor Platform and Authentication.