The Signal Platform is currently experiencing issues

Incident Report for Signal Advisors

Resolved

This incident has been resolved.
Posted May 27, 2025 - 12:38 EDT

Identified

The issue has been identified and we are waiting for the fix to take affect.
Posted May 27, 2025 - 10:32 EDT

Investigating

We are currently investigating an issue preventing users from logging into the Signal Platform. We will provide an update when we have identified the core problem.
Posted May 27, 2025 - 09:26 EDT
This incident affected: Advisor Platform and Firelight Service.