Mailing label creation is currently broken

Incident Report for Signal Advisors

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 15:56 EDT

Identified

The mailing label creation tool in the platform is currently experiencing issues, and may not properly generate mailing labels. We are working with our vendor to get it back up and running as soon as possible.
Posted Jul 23, 2026 - 14:25 EDT
This incident affected: Advisor Platform.