Phone System

Incident Report for Signal Advisors

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 13:38 EDT

Update

Issue has been resolved.
Posted Mar 31, 2025 - 13:34 EDT

Investigating

We are currently experiencing issues with our phone system. This may result in dropped calls, inability to make or receive calls, or delays in call routing.

Our team is actively investigating the issue and working with our vendor to resolve it as quickly as possible. We will provide updates here as more information becomes available.

Thank you for your patience.
Posted Mar 31, 2025 - 12:44 EDT
This incident affected: Phone System.