Document Upload Degraded

Incident Report for Signal Advisors

Resolved

This incident has been resolved.
Posted Jun 15, 2026 - 18:10 EDT

Investigating

We are currently investigating an issue with regards to document uploads failing.
Posted Jun 15, 2026 - 14:39 EDT
This incident affected: Advisor Platform.