Phone System Outage

Incident Report for Signal Advisors

Resolved

The phone system issue has been fully restored, and all services are now back to normal. We have confirmed stability and full functionality. Thank you for your patience and understanding during this time.
Posted Jun 25, 2025 - 13:25 EDT

Investigating

We are currently experiencing issues with our phone system. This may result in dropped calls, inability to make or receive calls, or delays in call routing.

Our team is actively investigating the issue and working with our vendor to resolve it as quickly as possible. We will provide updates here as more information becomes available.

Thank you for your patience.
Posted Jun 25, 2025 - 11:58 EDT
This incident affected: Phone System.